Jump to content
  • 0
Szmycu

Infraestrutura How to get newer version of client Rsa Decrypt Failed

Question

Szmycu    0
Szmycu

Before asking your question, make sure you have read the section rules and guide below:

https://forums.otserv.com.br/index.php?/forums/topic/168583-regras-da-seção/

https://forums.otserv.com.br/index.php?/forums/topic/165121-como- Fazer-uma-pergunta-ou-o-grande-guia-do-usuário-com-dúvidas/

Note: do not delete this predefined form, fill it in correctly to post your topic!

In a few words, describe the base used. (Server name / Client name / Website name / etc.).

Base:

OTServBR-Global 12.x

 

What's your question?

Im using this server and before Im used client 12.64 without warning

Now I using client 12.71 and get the warning

 [warning] [ProtocolGame::onRecvFirstMessage] - RSA Decrypt Failed 

I have Znote ACC its becouse of znote_login.php ? 

Or i Have to change somerhing i protocol.cpp or somewhere?

 

Do you have the code available? If you have, post it in the code box inside the spoiler below:

Spoiler

 

 

Do you have an image that can help with the problem? If so, attach it inside the spoiler below:

Spoiler

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
Majesty    1,755
Majesty

I tested with ZnoteAAC + ZnoteAAC login.php and it's working.

Share this post


Link to post
Share on other sites
  • 0
Majesty    1,755
Majesty

Change the RSA key in the client 12.7.

Share this post


Link to post
Share on other sites
  • 0
Szmycu    0
Szmycu
31 minutos atrás, Majesty disse:

Change the RSA key in the client 12.7.

I used this on client 12.70 and am able to login and play but i got this error

I can change rsa but for what rsa i have to change? From where should i got this?

i got these messages even if im not connected with game 

Citar

[warning] [ProtocolGame::onRecvFirstMessage] - RSA Decrypt Failed

What i have found more on client 12.71 i got debug when clicking on items in depo market

 Didn't send news query with params ( 0 2 ) (URL: QUrl("https://localhost/login.php") ) due to too many retries.
2021-11-18, 01:01:45: Request connection to gameserver 

on 12.64 i do not have this error 

Share this post


Link to post
Share on other sites
  • 0
Majesty    1,755
Majesty
  • 0
Majesty    1,755
Majesty

I didn't said to change key.pem. I tested this pull request (https://github.com/opentibiabr/otservbr-global/pull/311) with client 12.72 (https://github.com/dudantas/tibia-client/tree/12.72.11206) and it's working fine here.

Access the discord to follow the updates: https://discordapp.com/invite/3NxYnyV

Share this post


Link to post
Share on other sites
  • 0
Szmycu    0
Szmycu
1 hora atrás, Majesty disse:

I didn't said to change key.pem. I tested this pull request (https://github.com/opentibiabr/otservbr-global/pull/311) with client 12.72 (https://github.com/dudantas/tibia-client/tree/12.72.11206) and it's working fine here.

Access the discord to follow the updates: https://discordapp.com/invite/3NxYnyV

thx for help again. what i have done 

1. Downloaded newest files from github (I have seen there was changes in src and data folder in some files)

2. Compiled new server .otbr

3. Server running without errors with [2021-18-11 13:02:13.369] [info] Server protocol: 12.72

4. I changed 12.72 client by this 

5. Client works and im connected to game . Market in depo do not makes debugs now its good

6. Stil warnings [2021-18-11 13:04:40.220] [warning] [ProtocolGame::onRecvFirstMessage] - RSA Decrypt Failed

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×