Jump to content
Sign in to follow this  
josejunior23

Advanced Pet System With Races!

Recommended Posts

dyego2009

Bom em breve Postarei ele Aque , so funciona em 8.6!

Share this post


Link to post
Share on other sites
dyego2009

Consegui fazer ele Funcionar em 9.8+ mas está dando um Erro em GetLvlStage vou tentar arrumar e Posto Aque.

Share this post


Link to post
Share on other sites
LightTenshi

Estamos Aguardando Ansiosos dyego2009.

 

Seria Bom Que Você Fosse Postando E Editando Independente De Erros Ainda Presentes.

Share this post


Link to post
Share on other sites
Codenome

Pessoal que esta com o erro/bug/problema de imcompatibilidade, que ao comprar o pet, recebe a mensagem de que ainda nao comprou...

 

Vão em data/lib no arquivo APS_lib, procurem por:

 

[spoiler=Atual]

function createPet(cid, race_id, hp, mana)

setPetLastHealth(cid, 0)

local sets = {

{aps_storages.id, 1},

{aps_storages.race, race_id},

{aps_storages.level, 1},

{aps_storages.ml, 1},

{aps_storages.manaMax, mana},

{aps_storages.mana, mana},

{aps_storages.health, hp}

}

setPlayerMultiStorages(cid, sets)

end

 

 

E substituam por:

 

[spoiler=Novo]

function createPet(cid, race_id, hp, mana)

setPetLastHealth(cid, 0)

setPlayerStorageValue(cid, aps_storages.id, 1)

setPlayerStorageValue(cid, aps_storages.race, race_id)

setPlayerStorageValue(cid, aps_storages.level, 1)

setPlayerStorageValue(cid, aps_storages.ml, 1)

setPlayerStorageValue(cid, aps_storages.manaMax, mana)

setPlayerStorageValue(cid, aps_storages.mana, mana)

setPlayerStorageValue(cid, aps_storages.health, hp)

end

 

 

Se voce teve esse erro, provavelmente vai ter alguns outros simples tambem, nada muito trabalhoso, mais vale muito apena :)

 

[spoiler=Obs]

1 - Não sei se poderia ter ressuscitado esse tópico, mais acho que vai ajudar muitos...

2- Foram feitas alterações desde a ultima vez que usei( a 1~2 anos) por isso deu imcompatibilidade aqui(o que não aconteceu no passado :P). Enfim se eu encontrar mais erros, poderei ajudar se me mandarem PM, vlw.

 

Share this post


Link to post
Share on other sites
Texlin22
esta dando esse erro:

 

[03/08/2014  16:29:26] [Warning - NpcScript::NpcScript] Can not load script: Pet-Trainer.lua

[03/08/2014  16:29:26] cannot open Pet-Trainer.lua: No such file or directory

como arruma??

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×