Jump to content
  • 0
FaelDanil

Programação Erro de Compilação TFS 1.3 - 8.6

Question

FaelDanil

Antes de fazer a sua pergunta, tenha certeza de ter lido as regras da seção e o guia abaixo:

https://forums.otserv.com.br/index.php?/forums/topic/168583-regras-da-seção/

https://forums.otserv.com.br/index.php?/forums/topic/165121-como-fazer-uma-pergunta-ou-o-grande-guia-do-usuário-com-dúvidas/

Descreva em algumas palavras a base utilizada. (Nome do servidor / Nome do cliente / Nome do website / etc.).

Ex: The Forgotten Server 1.3, Versão: 10.98.

Base:

The Forgotten Server 1.3, Versão: 8.6

Qual é a sua pergunta?

Rapeizes essa área de compilação sempre me da nó no cérebro, por ser leigo nessa área.  Então acredito que tenha gente boa aqui que possa me ajudar.

Bom eu estou montando um projeto Tibia Global 8.6 com TFS 1.3.

Estou usando esse TFS do Nekiro:

Hidden Content

    Sign In here or Sign Up here to see this hidden content.

À partir do tutorial aqui do fórum do @Majesty, segui tudo. Na hora compilação da um erro, que acredito que seja, que não acha a biblioteca direcionada.

 

Você tem o código disponível? Se tiver poste-o na caixa de código que está dentro do spoiler abaixo:

Spoiler

Hidden Content

    Sign In here or Sign Up here to see this hidden content.

 

Você tem alguma imagem que possa auxiliar no problema? Se sim, anexe-a dentro do spoiler abaixo:

Spoiler

Abaixo uns prints pra entenderem melhor

Desde já agradeço quem puder da uma força. Preciso apenas disso pra iniciar um projeto que estou a um tempo elaborando e certeza que será de sucesso.

Hidden Content

    Sign In here or Sign Up here to see this hidden content.

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
P4NSB

Relacionado ao Boost/asio.hpp tenta verificar se a versão do Visual Studio e do pacote dele está correta
Eu estava com os mesmos problemas, fiquei 6 dias tentando compilar e não dava, minha solução foi a seguinte...
Desinstalei todos os pacotes e programas vinculados ao Visual Studio(Inclusive as livrarias que já havia baixado, apaguei tudo relacionado MESMO)
Instalei novamente o Visual Studio 2017(v141) <- deve ser este (Pode instalar todos igual diz no tutorial sem problemas)
Instalei o GitGUI e o POWERSHELL Usando o powershell baixei as livrarias, também tive um erro ao baixar a livraria boost, mas baixando ela separadamente deu certo...
Se não conseguir com PowerShell usa o GitGui vai tentando ate conseguir baixar todas as livrarias
Utilizei tanto o tutorial do OTServBR quanto o do GitHub
Depois de instaladas executa o comando de integração, para o visual studio reconhecer o que você baixou das livrarias
Para compilar: Build -> Configuration Manager -> Release 64x
Propriedades do TFS: Visual Studio 2017(v141) SDK Version 10.0.17763.0
Executar e prontinho está feito, qualquer coisa só responder aqui que ajudo...

Share this post


Link to post
Share on other sites
  • 0
Majesty

O TFS 1.3 com downgrade para versão 8.6 feito pelo Nekiro compila com o vcpkg:

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×